Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 18, 2026 - 22:40 UTC
Scheduled
We will be performing scheduled maintenance on our roaming infrastructure tonight.
**Maintenance Window:** - Start: March 18, 2026 at 10:00 PM UTC - End: March 19, 2026 at 1:00 AM UTC
**What to Expect:** During this window, wireless customers may experience brief, intermittent disruptions to data connectivity while roaming internationally. Each disruption is expected to last only a few minutes as systems are sequentially restarted.
**Who Is Affected:** Customers with IoT devices or SIMs currently roaming on international networks may notice short periods of reduced connectivity. Domestic service is not affected.
This maintenance is part of our ongoing infrastructure optimization to ensure continued stability and peak performance of our global wireless network.
We apologize for any inconvenience and appreciate your patience.
Posted Mar 18, 2026 - 22:36 UTC
This scheduled maintenance affected: Programmable Wireless.